re = /(፻\S+?\s)(\S+?\s)*?(\S+?)፻/m
str = '፻this test works፻
፻this test does not work፻'
subst = '$1፻$2፻$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result