const regex = /\b(?:[^a ]*a){3}\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[^a ]*a){3}\\S*', 'gm')
const str = `Anastasia would like to have a banana split. bananafoosbar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}