re = /\b(?:[^a ]*a){3}\S*/m
str = 'Anastasia would like to have a banana split. bananafoosbar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end