$re = '/\b(?:[^a ]*a){3}\S*/m';
$str = 'Anastasia would like to have a banana split. bananafoosbar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);