using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?'cle1'.+?) : (?'valeur1'.+))|(?:(?'cle2'.+?) : )|(?: : (?'valeur2'.+))|(?'etc'\.\.\.|…)|(?'cle3'.+))$";
string input = @"Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
: Dominick Dunne
...
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}