$re = '/^(?:(?:(?\'cle1\'.+?) : (?\'valeur1\'.+))|(?:(?\'cle2\'.+?) : )|(?: : (?\'valeur2\'.+))|(?\'etc\'\.\.\.|…)|(?\'cle3\'.+))$/m';
$str = 'Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
: Dominick Dunne
...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);