using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d:)(?<!\d)[0-5]?\d:[0-5]\d(?!:?\d)";
string input = @"1:02:40 1:06:10 1:08:15 1:12:25 1:17:08 1:20:34 20:23 1:23 01:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}