const regex = new RegExp('(?<!\\d:)(?<!\\d)[0-5]?\\d:[0-5]\\d(?!:?\\d)', 'gm')
const str = `1:02:40 1:06:10 1:08:15 1:12:25 1:17:08 1:20:34 20:23 1:23 01:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}