import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d:)(?<!\\d)[0-5]?\\d:[0-5]\\d(?!:?\\d)";
final String string = "1:02:40 1:06:10 1:08:15 1:12:25 1:17:08 1:20:34 20:23 1:23 01:00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}