#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)\d{1,3}(?:\.\d{3})*$"
Local $sString = "VISTA AES TIETE E UNT N2 600" & @CRLF & _
"VISTA IT AUUNIBANCO PN N1 1.400" & @CRLF & _
"OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000" & @CRLF & _
"100.000" & @CRLF & _
"OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")