$re = '/(?<!\S)\d{1,3}(?:\.\d{3})*$/m';
$str = 'VISTA AES TIETE E UNT N2 600
VISTA IT AUUNIBANCO PN N1 1.400
OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000
100.000
OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);