import re
regex = re.compile(r"(?<!\S)\d{1,3}(?:\.\d{3})*$", flags=re.MULTILINE)
test_str = ("VISTA AES TIETE E UNT N2 600\n"
"VISTA IT AUUNIBANCO PN N1 1.400\n"
"OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000\n"
"100.000\n"
"OPCAO DE VENDA 04/21 COGNP450ON 4,50COGNE 100.000.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")