import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<font color=\"([^\"]*)\">(.*?)<\\/font>";
final String string = "<pre><font color=\"#4E9A06\"><b>alecto@styx</b></font>:<font color=\"#3465A4\"><b>~</b></font>$ ls apps\n"
+ "<font color=\"#4E9A06\"><b>Bitwarden-1.27.1-x86_64_a6df18330216c2546e435c5a9c5df432.AppImage</b></font>\n"
+ "<font color=\"#3465A4\"><b>gitkraken</b></font>\n"
+ "<font color=\"#4E9A06\"><b>session-desktop-linux-x86_64-1.6.7_18e4489c1ba2c40986ad03ca6522e187.AppImage</b></font>\n"
+ "<font color=\"#3465A4\"><b>sources</b></font>\n"
+ "<font color=\"#4E9A06\"><b>alecto@styx</b></font>:<font color=\"#3465A4\"><b>~</b></font>$ \n"
+ "</pre>\n";
final String subst = "<span style=\"color: $1\">$2</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}