# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<font color=\"([^\"]*)\">(.*?)<\/font>"
test_str = ("<pre><font color=\"#4E9A06\"><b>alecto@styx</b></font>:<font color=\"#3465A4\"><b>~</b></font>$ ls apps\n"
"<font color=\"#4E9A06\"><b>Bitwarden-1.27.1-x86_64_a6df18330216c2546e435c5a9c5df432.AppImage</b></font>\n"
"<font color=\"#3465A4\"><b>gitkraken</b></font>\n"
"<font color=\"#4E9A06\"><b>session-desktop-linux-x86_64-1.6.7_18e4489c1ba2c40986ad03ca6522e187.AppImage</b></font>\n"
"<font color=\"#3465A4\"><b>sources</b></font>\n"
"<font color=\"#4E9A06\"><b>alecto@styx</b></font>:<font color=\"#3465A4\"><b>~</b></font>$ \n"
"</pre>\n")
subst = "<span style=\"color: $1\">$2</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.