using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^<,""]+)|([^>\n]+(?=<))|\n|.*<strong>|<\/strong\>.*|<\/?ul>";
string substitution = @"\1 \2";
string input = @"""1"",""ANYDATA-481190-131"",""<ul>
<li><strong>487410-131</strong> (prateado)</li>
<li><strong>502478-131</strong></li>
<li><strong>555996-131</strong> (prateado)</li>
<li><strong>AEQT6T11110</strong></li>
<li><strong>AEQT6T00210</strong></li>
</ul>""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}