re = /("[^<,"]+)|([^>\n]+(?=<))|\n|.*<strong>|<\/strong\>.*|<\/?ul>/
str = '"1","ANYDATA-481190-131","<ul>
<li><strong>487410-131</strong> (prateado)</li>
<li><strong>502478-131</strong></li>
<li><strong>555996-131</strong> (prateado)</li>
<li><strong>AEQT6T11110</strong></li>
<li><strong>AEQT6T00210</strong></li>
</ul>"'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result