#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http|https):\/\/.*\/@.*"
Local $sString = "https://instance.xyz/home" & @CRLF & _
"http://instance.xyz/home" & @CRLF & _
"http://instance.xyz/@username/following" & @CRLF & _
"https://instance.xyz/@username/following" & @CRLF & _
"http://instance.xyz/@username" & @CRLF & _
"https://instance.xyz/@username" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")