using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/.*\/@.*";
string input = @"https://instance.xyz/home
http://instance.xyz/home
http://instance.xyz/@username/following
https://instance.xyz/@username/following
http://instance.xyz/@username
https://instance.xyz/@username
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}