re = /(http|https):\/\/.*\/@.*/m
str = 'https://instance.xyz/home
http://instance.xyz/home
http://instance.xyz/@username/following
https://instance.xyz/@username/following
http://instance.xyz/@username
https://instance.xyz/@username
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end