using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^,]+,\""city\"":\""(?<city>[^\""]+)\"",\""state\"":\""(?<state>[^\""]+)";
string input = @"12345 noth test Avenue"",""city"":""test"",""state"":""test"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}