re = /^[^,]+,\"city\":\"(?<city>[^\"]+)\",\"state\":\"(?<state>[^\"]+)/m
str = '12345 noth test Avenue","city":"test","state":"test",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end