package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)CODE.*?CODE`)
var str = `Some stuff to keep <b>here</b>
CODE
<b>Replace gt and lt</b>
<i>inside <script>this</script> code</i>
CODE
Some more stuff to keep <b>here</b>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}