import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)CODE.*?CODE";
final String string = "Some stuff to keep <b>here</b>\n\n"
+ "CODE\n"
+ "<b>Replace gt and lt</b>\n"
+ "<i>inside <script>this</script> code</i>\n"
+ "CODE\n\n"
+ "Some more stuff to keep <b>here</b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}