$re = '/(?s)CODE.*?CODE/m';
$str = 'Some stuff to keep <b>here</b>
CODE
<b>Replace gt and lt</b>
<i>inside <script>this</script> code</i>
CODE
Some more stuff to keep <b>here</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);