#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?<=>)(.*?)(?=<\/address)"
Local $sString = "<address>" & @CRLF & _
"Firstname Lastname<br />" & @CRLF & _
"Address 1<br />" & @CRLF & _
"ZIP City<br />" & @CRLF & _
"Country</address>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")