$re = '/(?s)(?<=>)(.*?)(?=<\/address)/m';
$str = '<address>
Firstname Lastname<br />
Address 1<br />
ZIP City<br />
Country</address>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);