re = /(?s)(?<=>)(.*?)(?=<\/address)/m
str = '<address>
Firstname Lastname<br />
Address 1<br />
ZIP City<br />
Country</address>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end