#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([.,])+|( )+"
Local $sString = "hello,,, world, how are you?.. hi...,.,."
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)