using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([.,])+|( )+";
string substitution = @"$1$2";
string input = @"hello,,, world, how are you?.. hi...,.,.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}