use strict;
my $str = 'hello,,, world, how are you?.. hi...,.,.';
my $regex = qr/([.,])+|( )+/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";