using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{5,10}\/|$)(?:who|what).*?(?=\/|$)";
string input = @"http://www.test.com/who12/foo
http://www.test.com/who12";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}