$re = '/(?=.{5,10}\/|$)(?:who|what).*?(?=\/|$)/';
$str = 'http://www.test.com/who12/foo
http://www.test.com/who12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);