re = /(?=.{5,10}\/|$)(?:who|what).*?(?=\/|$)/
str = 'http://www.test.com/who12/foo
http://www.test.com/who12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end