using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w+(?=\s*[,()])";
string input = @"MethodName(int? Property1, string Property2, List<int?> Property3)
MethodName (int? Property1 , string Property2, List<int?> Property3)
MethodName()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}