re = /\b\w+(?=\s*[,()])/m
str = 'MethodName(int? Property1, string Property2, List<int?> Property3)
MethodName (int? Property1 , string Property2, List<int?> Property3)
MethodName()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end