using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=win_(?!dev_))|(?<=win_dev_)).*?(?=_)";
string input = @"', 'win_dev_host123_12345'
', 'win_host123_12345'
ev_
win_dev_mmmm
win_dev_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}