const regex = /(?:(?<=win_(?!dev_))|(?<=win_dev_)).*?(?=_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=win_(?!dev_))|(?<=win_dev_)).*?(?=_)', 'gm')
const str = `', 'win_dev_host123_12345'
', 'win_host123_12345'
ev_
win_dev_mmmm
win_dev_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}