import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=win_(?!dev_))|(?<=win_dev_)).*?(?=_)";
final String string = "', 'win_dev_host123_12345'\n"
+ "', 'win_host123_12345'\n"
+ "ev_ \n"
+ "win_dev_mmmm\n"
+ "win_dev_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}