#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w([.-]?))+\@\w+\.\w+"
Local $sString = "valid:" & @CRLF & _
"benji_yang@basic.cn" & @CRLF & _
"benji.yang@roolbox.com" & @CRLF & _
"benji-yang@gmail.org" & @CRLF & _
"" & @CRLF & _
"invalid:" & @CRLF & _
"@gmail.com" & @CRLF & _
"1@.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")