package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w([.-]?))+\@\w+\.\w+`)
var str = `valid:
benji_yang@basic.cn
benji.yang@roolbox.com
benji-yang@gmail.org
invalid:
@gmail.com
1@.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}