re = /(\w([.-]?))+\@\w+\.\w+/
str = 'valid:
benji_yang@basic.cn
benji.yang@roolbox.com
benji-yang@gmail.org
invalid:
@gmail.com
1@.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end