package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((http)|(https)|(rtp)|(rtsp)|(udp)):\/\/`)
var str = `http://
https://
rtp://
rtsp://
udp://
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}