$re = '/^((http)|(https)|(rtp)|(rtsp)|(udp)):\/\//m';
$str = 'http://
https://
rtp://
rtsp://
udp://
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);