re = /^((http)|(https)|(rtp)|(rtsp)|(udp)):\/\//m
str = 'http://
https://
rtp://
rtsp://
udp://
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end