import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:p(?:i|ow)|m(?:in|ax))\\b(*SKIP)(*FAIL)|[^0-9().,+*/\\s-]+";
final String string = "25 * (233 - 1.5)\n\n"
+ "pow(25,2) / pi(); hack the pentagon;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}