$re = '~\b(?:p(?:i|ow)|m(?:in|ax))\b(*SKIP)(*FAIL)|[^0-9().,+*/\s-]+~m';
$str = '25 * (233 - 1.5)
pow(25,2) / pi(); hack the pentagon;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;