use strict;
my $str = '25 * (233 - 1.5)
pow(25,2) / pi(); hack the pentagon;';
my $regex = qr~\b(?:p(?:i|ow)|m(?:in|ax))\b(*SKIP)(*FAIL)|[^0-9().,+*/\s-]+~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";