# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"USER \((\w+)\)$"
test_str = ("Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)\n"
"show_time_of_pid(\"Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)\n"
"Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)\n"
"Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)\n"
"Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \\\"0xDEADBEEF\\\"\n"
"Jul 6 14:04:01 computer.name CRON[29440]: USER (naughty_user)\n"
"Jul 6 14:05:01 computer.name CRON[29440]: USER (naughty_user)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.