const regex = /\G[^" \n]*(?:(?<!\\)"[^\n"]*(?<!\\)"[^" \n]*)*\K +/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G[^" \\n]*(?:(?<!\\\\)"[^\\n"]*(?<!\\\\)"[^" \\n]*)*\\K +', 'gm')
const str = `key1=value1 key1=value1 spaces="some spaces in text" nested1="key2=value2 key2=value2 key2=value2" nested2="key2=value2, key2=value2, key2=value2" quoted="his name is \\"no body\\""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}