$re = '/\G[^" \n]*(?:(?<!\\\\)"[^\n"]*(?<!\\\\)"[^" \n]*)*\K +/m';
$str = 'key1=value1 key1=value1 spaces="some spaces in text" nested1="key2=value2 key2=value2 key2=value2" nested2="key2=value2, key2=value2, key2=value2" quoted="his name is \\"no body\\""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);